PE-CE de enlace entre el funcionamiento de camuflaje avanzada

Las características de muchos pequeños siempre se puede decir que no es muy flexible, también puedo decir que es muy complicado.Tuve una experiencia, si tienes que Isis, encontrará la ruta de aprendizaje encontró un vecino muy rápido, pero se necesita un poco de tiempo.Fácil de usar es la mejor de la red de la comunidad, un beso es el principio, no se., stupid.

Este experimento el siguiente describe una situación.Hay una empresa que tiene cuatro divisiones, la división entre proveedores de servicios de Internet a través de una conexión VPN.PE-CE entre en funcionamiento el area de 0, que CE-3 y CE-4 tiene un enlace de baja velocidad, también funciona en el area 0.

Es el resultado de esta ruta subóptima topología de la causa.El flujo de datos de la División de superbackbone entre todos los proveedores de servicios de Internet no caminar, caminar es el vínculo entre CE-3 y CE-4 puerta trasera.Las razones de esta por la sencilla razón de que es una prioridad de rutas: O>O IA.

Para cambiar esta situación puede utilizar sham-link (disfrazado de enlace), se puede establecer un vínculo entre el pe para inundaciones LSA, es decir, el PE puede transmitir o entre la ruta.Sham-link puede considerarse un circuito de acuerdo con las características de la demanda, es necesario el circuito no LSA actualizar periódicamente, así que ahorra ancho de banda, aliviar la carga de red.

Deberá prestarse especial atención a la creación de Sham-link es, él es, como el cliente VPN dentro de la dirección de espacio y, por lo tanto, la dirección de la necesidad de declarar después de MP-BGP fue a punta de pe a aprender antes de poder establecer una conexión.En el entorno de la producción real, también deben tenerse en cuenta los programas de creación de la dirección de abordar y que cuenta con la interfaz.


Configuración básica

R1:

!

hostname CE1-A

!

interface Loopback0

ip address 172.16.10.1 255.255.255.0

ip ospf network point-to-point

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.15

encapsulation dot1Q 15

ip address 15.1.1.1 255.255.255.0

!

router ospf 100

router-id 1.1.1.1

log-adjacency-changes

passive-interface Loopback0

network 15.1.1.1 0.0.0.0 area 0

network 172.16.10.0 0.0.0.255 area 0

distribute-list 10 in FastEthernet0/0.15 #Aquí el uso de listas de distribución de la denegación de la ruta de importancia es la ruta más directa de la tabla

!

access-list 10 deny 34.1.1.0 0.0.0.255

access-list 10 deny 35.1.1.0 0.0.0.255

access-list 10 deny 27.1.1.0 0.0.0.255

access-list 10 deny 47.1.1.0 0.0.0.255

access-list 10 permit any

!

R2:

!

hostname CE2-A

!

interface Loopback0

ip address 172.16.20.1 255.255.255.0

ip ospf network point-to-point

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.27

encapsulation dot1Q 27

ip address 27.1.1.2 255.255.255.0

!

router ospf 100

router-id 2.2.2.2

log-adjacency-changes

passive-interface Loopback0

network 27.1.1.2 0.0.0.0 area 0

network 172.16.20.0 0.0.0.255 area 0

distribute-list 10 in FastEthernet0/0.27

!

access-list 10 deny 34.1.1.0 0.0.0.255

access-list 10 deny 35.1.1.0 0.0.0.255

access-list 10 deny 15.1.1.0 0.0.0.255

access-list 10 deny 47.1.1.0 0.0.0.255

access-list 10 permit any

R3:

hostname CE3-A

!

interface Loopback0

ip address 172.16.30.1 255.255.255.0

ip ospf network point-to-point

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.34

encapsulation dot1Q 34

ip address 34.1.1.3 255.255.255.0

!

interface FastEthernet0/0.35

encapsulation dot1Q 35

ip address 35.1.1.3 255.255.255.0

!

router ospf 100

router-id 3.3.3.3

log-adjacency-changes

passive-interface Loopback0

network 34.1.1.3 0.0.0.0 area 0

network 35.1.1.3 0.0.0.0 area 0

network 172.16.30.0 0.0.0.255 area 0

distribute-list 10 in FastEthernet0/0.34

distribute-list 10 in FastEthernet0/0.35

!

access-list 10 deny 15.1.1.0 0.0.0.255

access-list 10 deny 27.1.1.0 0.0.0.255

access-list 10 deny 47.1.1.0 0.0.0.255

access-list 10 permit any

!

R4:

hostname CE4-A

!

boot-start-marker

!

interface Loopback0

ip address 172.16.40.1 255.255.255.0

ip ospf network point-to-point

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.34

encapsulation dot1Q 34

ip address 34.1.1.4 255.255.255.0

!

interface FastEthernet0/0.47

encapsulation dot1Q 47

ip address 47.1.1.4 255.255.255.0

!

router ospf 100

router-id 4.4.4.4

log-adjacency-changes

passive-interface Loopback0

network 34.1.1.4 0.0.0.0 area 0

network 47.1.1.4 0.0.0.0 area 0

network 172.16.40.0 0.0.0.255 area 0

distribute-list 10 in FastEthernet0/0.34

distribute-list 10 in FastEthernet0/0.47

!

access-list 10 deny 15.1.1.0 0.0.0.255

access-list 10 deny 27.1.1.0 0.0.0.255

access-list 10 deny 35.1.1.0 0.0.0.255

access-list 10 permit any

R5:

!

hostname PE1-AS1

!

ip cef

!

ip vrf VPN-A

rd 1:0

route-target export 1:0

route-target import 1:0

!

mpls label range 500 599

mpls label protocol ldp

!

interface Loopback0

ip address 5.5.5.5 255.255.255.255

isis circuit-type level-2-only

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.15

encapsulation dot1Q 15

ip vrf forwarding VPN-A

ip address 15.1.1.5 255.255.255.0

!

interface FastEthernet0/0.35

encapsulation dot1Q 35

ip vrf forwarding VPN-A

ip address 35.1.1.5 255.255.255.0

!

interface FastEthernet0/0.56

encapsulation dot1Q 56

ip address 56.1.1.5 255.255.255.0

ip router isis

mpls ldp discovery transport-address interface

mpls ip

isis circuit-type level-2-only

!

router ospf 100 vrf VPN-A

router-id 5.5.5.5

log-adjacency-changes

redistribute bgp 1 subnets

network 15.1.1.5 0.0.0.0 area 0

network 35.1.1.5 0.0.0.0 area 0

!

router isis

net 47.5670.0000.0005.00

is-type level-2-only

metric-style wide

passive-interface Loopback0

!

router bgp 1

bgp router-id 5.5.5.5

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 7.7.7.7 remote-as 1

neighbor 7.7.7.7 update-source Loopback0

!

address-family vpnv4

neighbor 7.7.7.7 activate

neighbor 7.7.7.7 send-community extended

exit-address-family

!

address-family ipv4 vrf VPN-A

redistribute ospf 100 vrf VPN-A

no synchronization

exit-address-family

!

ip http server

no ip http secure-server

!

mpls ldp router-id Loopback0 force

!

R6:

hostname P-AS1

!

ip cef

!

mpls label range 600 699

mpls label protocol ldp

!

interface Loopback0

ip address 6.6.6.6 255.255.255.255

isis circuit-type level-2-only

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.56

encapsulation dot1Q 56

ip address 56.1.1.6 255.255.255.0

ip router isis

mpls ldp discovery transport-address interface

mpls ip

isis circuit-type level-2-only

!

interface FastEthernet0/0.67

encapsulation dot1Q 67

ip address 67.1.1.6 255.255.255.0

ip router isis

mpls ldp discovery transport-address interface

mpls ip

isis circuit-type level-2-only

!

router isis

net 47.5670.0000.0006.00

is-type level-2-only

metric-style wide

passive-interface Loopback0

!

mpls ldp router-id Loopback0 force

!

R7:

hostname PE2-AS1

!

ip cef

!

ip vrf VPN-A

rd 1:0

route-target export 1:0

route-target import 1:0

!

no ip domain lookup

!

mpls label range 700 799

mpls label protocol ldp

!

interface Loopback0

ip address 7.7.7.7 255.255.255.255

isis circuit-type level-2-only

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.27

encapsulation dot1Q 27

ip vrf forwarding VPN-A

ip address 27.1.1.7 255.255.255.0

!

interface FastEthernet0/0.47

encapsulation dot1Q 47

ip vrf forwarding VPN-A

ip address 47.1.1.7 255.255.255.0

!

interface FastEthernet0/0.67

encapsulation dot1Q 67

ip address 67.1.1.7 255.255.255.0

ip router isis

mpls ldp discovery transport-address interface

mpls ip

isis circuit-type level-2-only

!

router ospf 100 vrf VPN-A

router-id 7.7.7.7

log-adjacency-changes

redistribute bgp 1 subnets

network 27.1.1.7 0.0.0.0 area 0

network 47.1.1.7 0.0.0.0 area 0

!

router isis

net 47.5670.0000.0007.00

is-type level-2-only

metric-style wide

passive-interface Loopback0

!

router bgp 1

bgp router-id 7.7.7.7

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 5.5.5.5 remote-as 1

neighbor 5.5.5.5 update-source Loopback0

!

address-family vpnv4

neighbor 5.5.5.5 activate

neighbor 5.5.5.5 send-community extended

exit-address-family

!

address-family ipv4 vrf VPN-A

redistribute ospf 100 vrf VPN-A

no synchronization

exit-address-family

!

mpls ldp router-id Loopback0 force

!

Después de terminar de revisar la configuración básica.

1. La equivalencia entre el cuerpo de pe VPN

PE1-AS1#sh ip bgp vpnv4 all summary

BGP router identifier 5.5.5.5, local AS number 1

BGP table version is 19, main routing table version 19

9 network entries using 1233 bytes of memory

18 path entries using 1224 bytes of memory

15/7 BGP path/bestpath attribute entries using 1860 bytes of memory

2 BGP extended community entries using 80 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 4397 total bytes of memory

BGP activity 9/0 prefixes, 18/0 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

7.7.7.7 4 1 48 48 19 0 0 00:31:50 9

2. La ruta de aprendizaje a la CE (la ruta en el cuadro de la no utilización de sham-link antes).

CE3-A(config)#do sh ip route os

172.16.0.0/24 is subnetted, 4 subnets

O 172.16.40.0 [110/11] via 34.1.1.4, 00:01:18, FastEthernet0/0.34

O 172.16.20.0 [110/31] via 34.1.1.4, 00:01:18, FastEthernet0/0.34

O 172.16.10.0 [110/21] via 35.1.1.5, 00:01:18, FastEthernet0/0.35

CE4-A(config)#do sh ip rou os

172.16.0.0/24 is subnetted, 4 subnets

O 172.16.30.0 [110/11] via 34.1.1.3, 00:01:35, FastEthernet0/0.34

O 172.16.20.0 [110/21] via 47.1.1.7, 00:01:35, FastEthernet0/0.47

O 172.16.10.0 [110/31] via 34.1.1.3, 00:01:35, FastEthernet0/0.34

De CE-3 y CE-4 anterior, podemos ver que son o de ruta.Esta es la mejor ruta.En ruta, o es la segunda mejor ruta o, si es Ia pero normal.La ruta de salida de pe router la siguiente muestra también que no superbackbone caminar, caminar es IGP y ese artículo, a saber, la puerta trasera de baja velocidad de enlace.

PE1-AS1#sh ip bgp vpnv4 all

BGP table version is 19, local router ID is 5.5.5.5

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

Route Distinguisher: 1:0 (default for vrf VPN-A)

* i15.1.1.0/24 7.7.7.7 40 100 0 ?

*> 0.0.0.0 0 32768 ?

* i27.1.1.0/24 7.7.7.7 0 100 0 ?

*> 35.1.1.3 40 32768 ?

* i34.1.1.0/24 7.7.7.7 20 100 0 ?

*> 35.1.1.3 20 32768 ?

* i35.1.1.0/24 7.7.7.7 30 100 0 ?

*> 0.0.0.0 0 32768 ?

* i47.1.1.0/24 7.7.7.7 0 100 0 ?

*> 35.1.1.3 30 32768 ?

* i172.16.10.0/24 7.7.7.7 41 100 0 ?

*> 15.1.1.1 11 32768 ?

* i172.16.20.0/24 7.7.7.7 11 100 0 ?

*> 35.1.1.3 41 32768 ?

* i172.16.30.0/24 7.7.7.7 21 100 0 ?

*> 35.1.1.3 11 32768 ?

Network Next Hop Metric LocPrf Weight Path

* i172.16.40.0/24 7.7.7.7 11 100 0 ?

*> 35.1.1.3 21 32768 ?

3. La interfaz de establecer que en el PE, y la redistribución en MP-BGP

PE1-AS1:

interface Loopback1

ip vrf forwarding VPN-A

ip address 172.16.5.1 255.255.255.255

router bgp 1

address-family ipv4 vrf VPN-A

network 172.16.5.1 mask 255.255.255.255

AS1-PE2 en la dirección de la interfaz de la misma acción, para 172.16.7.1

4. A ver si recibió de la ruta de la nueva versión.

PE1-AS1#sh ip b vpn all 172.16.7.1

BGP routing table entry for 1:0:172.16.7.1/32, version 25

Paths: (1 available, best #1, table VPN-A)

Not advertised to any peer

Local

7.7.7.7 (metric 20) from 7.7.7.7 (7.7.7.7)

Origin IGP, metric 0, localpref 100, valid, internal, best

Extended Community: RT:1:0

mpls labels in/out nolabel/712

Recibido.

El establecimiento de SHAM-LINK 5.

AS1-PE1:

router ospf 100 vrf VPN-A

area 0 sham-link 172.16.5.1 172.16.7.1

En el mismo acto AS1-PE2.

Si la operación normal de ver este mensaje,

*Mar 1 00:17:05.339: %OSPF-5-ADJCHG: Process 100, Nbr 5.5.5.5 on OSPF_SL0 from LOADING to FULL, Loading Done

Estamos ahora a ver la vista de tabla AS1-PE1 vecino que tiene tres vecinos, como se indica a continuación.:

PE1-AS1#sh ip os n

Neighbor ID Pri State Dead Time Address Interface

7.7.7.7 0 FULL/ - - 172.16.7.1 OSPF_SL0

3.3.3.3 1 FULL/DR 00:00:38 35.1.1.3 FastEthernet0/0.35

1.1.1.1 1 FULL/DR 00:00:34 15.1.1.1 FastEthernet0/0.15

Es uno de los 7.7.7.7 con sham-link establecido, su interfaz muestra es OSPF-SL0, y el establecimiento de vínculos virtuales algo similar.

Por supuesto, podemos utilizar la orden directa de sham-link IP para mostrar la vista más directamente a ver la creación de información.

PE1-AS1#sh ip ospf sham-links

Sham Link OSPF_SL0 to address 172.16.7.1 is up

Area 0 source address 172.16.5.1

Run as demand circuit

DoNotAge LSA allowed. Cost of using 1 State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40,

Hello due in 00:00:06

Adjacency State FULL (Hello suppressed)

Index 3/3, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

Pide de nuevo a la CE en ver la lista de envío.

CE3-A#sh ip route os

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks

O 172.16.40.0/24 [110/11] via 34.1.1.4, 00:00:03, FastEthernet0/0.34

O 172.16.20.0/24 [110/22] via 35.1.1.5, 00:00:03, FastEthernet0/0.35

O 172.16.10.0/24 [110/21] via 35.1.1.5, 00:00:03, FastEthernet0/0.35

O E2 172.16.5.1/32 [110/1] via 35.1.1.5, 00:00:03, FastEthernet0/0.35

O E2 172.16.7.1/32 [110/1] via 35.1.1.5, 00:00:03, FastEthernet0/0.35

Nota sobre la ruta de salida, a CE1 y CE2 son correctas, pero a CE4 o no, es el resultado deseado ir superbackbone y no la puerta trasera.

El valor de lograr a través de la modificación.El puede modificar por la puerta trasera de enlace también puede modificar el valor de sham-link.Modificar el método de lista de aquí no es muy simple.

CE3-A#sh ip rou os

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks

O 172.16.40.0/24 [110/22] via 35.1.1.5, 00:07:30, FastEthernet0/0.35

O 172.16.20.0/24 [110/22] via 35.1.1.5, 00:07:30, FastEthernet0/0.35

O 172.16.10.0/24 [110/21] via 35.1.1.5, 00:07:30, FastEthernet0/0.35

O E2 172.16.5.1/32 [110/1] via 35.1.1.5, 00:07:30, FastEthernet0/0.35

O E2 172.16.7.1/32 [110/1] via 35.1.1.5, 00:07:30, FastEthernet0/0.35

Eso es.

por Rocío en 11 de Mayo 2017 08:27 PM